Jump to content



Photo
- - - - -

Vita Problem


  • Please log in to reply
4 replies to this topic

#1 GreaterFel

GreaterFel

    CAG Veteran

  • CAGiversary!

Posted 14 May 2013 - 03:03 AM

I've been having an odd issue with my Vita touchscreen that I can't seem to find any answers on and I was hoping some other CAGs knew how to help. The problem is that the touchscreen seems to register me touching it, without me actually touching it. I just noticed this recently when I was trying to play Soul Sacrifice and DJMax Technika Tune.

Occasionally the Vita won't recognize that I am touching the screen, but I think this is because it is registering that I am touching the screen elsewhere. I've tried cleaning the screen (no visible cracks or scratches, by the way), thoroughly, and restoring/formatting the system and the problem still persists. I also just got off of the phone with Sony Support and they want me to pay $129.99 to send in the system and have it fixed (just out of warranty... of course). I would very much appreciate some advice on the issue. :)

#2 Rasen

Rasen

    CAGiversary!

  • CAGiversary!

Posted 14 May 2013 - 03:47 AM

Could you be touching the touchpad on the back of the Vita? That touch area is much too large.

That happened to me when I was playing Uncharted.

#3 GreaterFel

GreaterFel

    CAG Veteran

  • CAGiversary!

Posted 14 May 2013 - 04:32 AM

I did think that might be the issue, unfortunately I wasn't touching the rear touchpad. Something else I forgot to mention in the OP; I don't know if I can describe this properly, but I've noticed some weird black splotches that seem to be underneath the screen in areas that don't always seem to respond. You can't see the splotches when the screen is off, but during mostly black loading screens etc., you can see them slightly.

#4 thepattenfactor

thepattenfactor

    Resident Caffeinated Gamer

  • CAGiversary!

Posted 14 May 2013 - 06:48 AM

I had the same problem a few weeks ago in regards to the touch screen acting up. It just went away after a few days for me. It's most likely from water touching the screen.

I've had two Vitas out of the box and both have splotches during loading screens-- I'm 99% sure it's completely normal.

#5 GreaterFel

GreaterFel

    CAG Veteran

  • CAGiversary!

Posted 14 May 2013 - 04:01 PM

Glad to hear that it sorted itself out. I'll give it a few days and hope that the problem goes away. Thanks to both of you for your help.