Jump to content



Photo
- - - - -

PSP & Wireless Encryption - Any way to get WPA2 connected?


  • Please log in to reply
16 replies to this topic

#1 doubledown

doubledown

    Funky Daddy

  • CAGiversary!

Posted 16 October 2008 - 04:17 PM

My wireless network at home is encrypted with WPA2 and I noticed the PSP doesn't connect to it. Any way to get it connected without changing my security settings? This is horrible by Sony not to put this technology in yet.

I would rather not change all my other settings (Wii/PS3/Laptop)

#2 ceckman

ceckman

    CAGiversary!

  • CAGiversary!

Posted 17 October 2008 - 02:32 AM

I use WPA2 encryption and my PSP connects without problems.

Do you have the latest official firmware for your PSP? Have you updated your router's firmware?

If you have done both of the above and are still having problems you might want to post more specific information about your set-up so people can try to help you out.

Good Luck.

#3 doubledown

doubledown

    Funky Daddy

  • CAGiversary!

Posted 17 October 2008 - 12:46 PM

Here is my setup:
- Linksys WRT54G router using WPA2 encryption (AES I believe) - I should have the newest firmware as I upgraded it within the past couple of months...
- PSP with OFFICIAL 5.00 firmware using WPA (AES) encryption

Basically, it appears that they might connect, but it always times out.

Any suggestions?

#4 ceckman

ceckman

    CAGiversary!

  • CAGiversary!

Posted 18 October 2008 - 03:25 PM

I'm using the same brand and model of router so there is hope. :)

I'll make the following suggestion.

Do things one step at a time -

1) Go into your router settings and turn off security - Choose 'Disabled' from the drop down list under the Wireless --> Wireless Security setting (you're just doing this briefly so it should not compromise your network.) Then see if you can connect the PSP. If successful proceed to step 2. If you are not successful here we need to investigate other settings in your router. One thing I would suggest is making sure you don't have MAC address filtering on. If you do have it on, turn it off and try to reconnect. If you want to leave it on you will need to add your PSPs MAC to the filter.

2) If you were successful with #1 go back into the router and turn WPA2 with TKIP-AES on.

Then make the shared key something really simple and short - like 123. I'd choose numbers because they are not case sensitive and there is less chance to mess things up. I have found that when I try to connect to my network with non-computer appliances it often takes several attempts because I have a long and complex shared key - getting it right can take patience and time on devices that do not have a keyboard.

If you succeed with #2 then you know you can connect and it simply a matter of getting the same pass key.

Let me know how things go. If you run into problems let me know where they are and I'll try to help.

Oh, one final reminder, make sure you click SAVE whenever you change a setting in your router and try to only change one thing at a time. A stepwise approach may tke a little longer but it leads to much less frustration in my experience. Good Luck.

#5 doubledown

doubledown

    Funky Daddy

  • CAGiversary!

Posted 21 October 2008 - 11:43 PM

Thanks....my problem was I using WPA2 with AES only (not TKIP-AES). I switched that and I'm instantly working now...yeah!

#6 ceckman

ceckman

    CAGiversary!

  • CAGiversary!

Posted 23 October 2008 - 01:56 AM

Glad to hear you got it working!

#7 visualgap

visualgap

Posted 27 October 2008 - 03:01 AM

WOW!! how did you do that??? I tried to access to my WPA2 network but my psp shows "Not Supported"
so it won't let me... I'm using 5.00 firmware.

#8 doubledown

doubledown

    Funky Daddy

  • CAGiversary!

Posted 27 October 2008 - 12:19 PM

It was a setting on the router I had to change....

WPA2 with TKIP-AES is needed.

#9 visualgap

visualgap

Posted 28 October 2008 - 12:55 PM

I changed to WPA2 with TKIP-AES and got the same result "Not Supported." I'm also using Linksys WRT54G router. Please help!

#10 ceckman

ceckman

    CAGiversary!

  • CAGiversary!

Posted 29 October 2008 - 12:35 AM

You need to give us more info.

Go through my post step by step and tell me where the problems occur.

--------------------

I'll make the following suggestion.

Do things one step at a time -

1) Go into your router settings and turn off security - Choose 'Disabled' from the drop down list under the Wireless --> Wireless Security setting (you're just doing this briefly so it should not compromise your network.) Then see if you can connect the PSP. If successful proceed to step 2. If you are not successful here we need to investigate other settings in your router. One thing I would suggest is making sure you don't have MAC address filtering on. If you do have it on, turn it off and try to reconnect. If you want to leave it on you will need to add your PSPs MAC to the filter.

2) If you were successful with #1 go back into the router and turn WPA2 with TKIP-AES on.

Then make the shared key something really simple and short - like 123. I'd choose numbers because they are not case sensitive and there is less chance to mess things up. I have found that when I try to connect to my network with non-computer appliances it often takes several attempts because I have a long and complex shared key - getting it right can take patience and time on devices that do not have a keyboard.

If you succeed with #2 then you know you can connect and it simply a matter of getting the same pass key.

Let me know how things go. If you run into problems let me know where they are and I'll try to help.

Oh, one final reminder, make sure you click SAVE whenever you change a setting in your router and try to only change one thing at a time. A stepwise approach may tke a little longer but it leads to much less frustration in my experience. Good Luck.

#11 PSP5.01WRT54GS4.71

PSP5.01WRT54GS4.71

Posted 05 November 2008 - 01:47 AM

This is what I did:

Went to the LINKSYS admin web page:
Type http://192.168.1.1 or https://192.168.1.1
Enter Username/password

Click WIRELESS then WIRELESS SECURITY

My settings showed:
WPA2 Personal
TKIP+AES
Write down the WPA Shared Key (you'll be entering this key, not the hexadecimal key)

On your PSP:
Network Settings,
Infrastructure Mode,
[New Connection] type a name for the connection
Scan
Look for the SSID with WPA-PSK (TKIP)
Under WLAN Security Setting
CHOOSE WPA-PSK (AES)
Enter the WPA Shared Key from your Router into the PSP
Address Settings -> EASY
Choose a connection name, I left it at linksys
Click X to Save Settings
Click on Test Connection

"Connecting to the Access Point"
"Obtaining IP Address"
"Testing Internet Connection"
Scroll down the status screen and it should show "Succeeded" under the Internet Connections

Hope this works for everyone...it did for me...

#12 visualgap

visualgap

Posted 08 November 2008 - 07:38 PM

Ok guys I think something is wrong with my psp.
@Ceckman I was successful with #1, but when I turn WPA2 with TKIP+AES I get this on my psp after a scan:
SSID Security Signal Strength
home Not Supported 90%

Yes its on grey so I can't choose it.
@PSP5 how did you manage to pick yours??

Edited by visualgap, 08 November 2008 - 08:01 PM.


#13 ceckman

ceckman

    CAGiversary!

  • CAGiversary!

Posted 09 November 2008 - 10:35 PM

What firmware version is on your PSP?

Settings->System Settings->System Information

Version 5.01 is the latest.

The most recent versions support WPA2 so the only explanation if your PSP is unsupported is that you are using an older firmware.

You can download and update with the latest fimware version at the link below -

http://www.us.playst...stemUpdates/PSP

#14 visualgap

visualgap

Posted 12 November 2008 - 12:05 AM

same results.... are you sure PSP (5.01) supports WPA2?? I tried to find out on PSP official site but does not mention anything about WPA2 support..

#15 icpmattj

icpmattj

    CAGiversary!

  • CAGiversary!

Posted 12 November 2008 - 02:50 AM

My psp will not work with WPA2 PERSONAL AES but will work if i set my router to WPA2 PERSONAL TKIP+AES

im running the lastest *cough*unofficial *cough* firmware


I would keep it on but since i never use psp for internet theres not point seeing as the wii only supports

WPA - PSK (TKIP)
WPA - PSK (AES)
WPA2 - PSK (AES)

IM not sure what the ps3 supports but im sure its everything.

#16 laaj

laaj

Posted 12 November 2008 - 12:04 PM

But isn't connecting PSP to WPA2 with AES+TKIP setting same as just using WPA? I always thought AES = WPA2 and TKIP = WPA.




#17 visualgap

visualgap

Posted 12 November 2008 - 02:44 PM

now its working... but it shows WPA TKIP instead of WPA2 AES+TKIP