Jump to content



Photo
- - - - -

Help: Laptop won't run my steam games?!?!


  • Please log in to reply
8 replies to this topic

#1 Hybrid5006

Hybrid5006

    White Trash Ballin

  • CAGiversary!

Posted 22 July 2009 - 02:58 AM

I really want to play my Counter-Strike:Source, hell I'll even settle for Condition Zero, but my computer is being stubborn and runs the games at extremely low fps and insane lag. Tried fiddling with the video settings, but nothing seems to improve it. Condition Zero is old and should work... I play WarCraft 3: FT and everything runs smoothly.

Here are my specs: http://www.amazon.co...48231106&sr=1-1

I don't know what could be wrong. Is vista draining all the power out of my computer? Is there a problem with my graphic drivers? (tried updating them but they are up to date, there was a window that popped up on steam saying that it didn't recognize the type of graphics card I'm using)

#2 SOSTrooper

SOSTrooper

    θ = fractional occupancy

  • CAGiversary!

Posted 22 July 2009 - 03:07 AM

Nothing is wrong with your laptop, it's just that your laptop is not meant for gaming. It has "Mobile IntelĀ® Graphics Media Accelerator 4500MHD" as integrated video. In other words, it doesn't support recent games at playable framerates.

WC3 is less intensive of a 3D games, so it should run nice on integrated graphic, but more power hungry games like CS:Source will require better graphic power (something like a nVidia 9400/9500 or ATI 3650) to actually run at playable framerates and resolution. The odd thing is that Condition Zero should run smoothly as it is built on a 10+ year old engine. You should try running the original Half-Life and/or Quake III to see if you run into low fps problem.

Posted Image
| Intel Core i7 920 @ 3.8GHz | OCZ Gold 6GB (3x2GB) DDR3 1600 | Asus P6T Deluxe V2 | 2x Intel X18-M 80GB RAID0 |
| XFX HD 5870 | Corsair HX750W PSU | Thermalright Ultra Extreme 120 | Antec P180 v1.1 |


#3 Hybrid5006

Hybrid5006

    White Trash Ballin

  • CAGiversary!

Posted 22 July 2009 - 05:40 AM

Nothing is wrong with your laptop, it's just that your laptop is not meant for gaming. It has "Mobile IntelĀ® Graphics Media Accelerator 4500MHD" as integrated video. In other words, it doesn't support recent games at playable framerates.

WC3 is less intensive of a 3D games, so it should run nice on integrated graphic, but more power hungry games like CS:Source will require better graphic power (something like a nVidia 9400/9500 or ATI 3650) to actually run at playable framerates and resolution. The odd thing is that Condition Zero should run smoothly as it is built on a 10+ year old engine. You should try running the original Half-Life and/or Quake III to see if you run into low fps problem.



Half-Life 1 runs, but is still a bit laggy.

The weird thing is that the computer will even let me run Team Fortress 2 (same low frame rate)

#4 seen

seen

    CAGiversary!

  • CAGiversary!

Posted 22 July 2009 - 05:44 AM

With your computer, I suggest playing old school cs 1.6.

#5 Hybrid5006

Hybrid5006

    White Trash Ballin

  • CAGiversary!

Posted 22 July 2009 - 05:59 PM

With your computer, I suggest playing old school cs 1.6.


Same thing bro...

What I don't understand is, how is my laptop even able to run TF2, but won't run CS 1.6 smoothly...

#6 seen

seen

    CAGiversary!

  • CAGiversary!

Posted 22 July 2009 - 08:09 PM

Have you tried lowering graphics settings? Maybe its not auto-adjusting properly and needs to be done manually.

..Oh and I'd make sure my drivers were up to date.

#7 headpiece747

headpiece747

    I'm always angry

  • CAGiversary!

Posted 22 July 2009 - 08:47 PM

When I was laptopless (I know its not a word) and had to use my wife's dell that has the same intergrated video card, the only way to make it playable was to lower everything to the lowest settings and switch to 800x600 resolution. Ugly as hell but playable.

Also forgot also updated everything on the laptop from Vista SP2 to drivers (I think there was one for the video card too but don't know about yours.)
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image

#8 Hybrid5006

Hybrid5006

    White Trash Ballin

  • CAGiversary!

Posted 23 July 2009 - 01:38 AM

Lowering the settings doesn't do anything for 1.6 and condition zero. It does help a little on Counter-Strike Source and it got my around 20-30 fps, but I truly need more than that. (no scoping ain't easy)

I'll probably end up selling this one and get another laptop with a better card. Friend has one with a 9600M GT and it runs source nicely.

#9 Gregalor

Gregalor

    CAGiversary!

  • CAGiversary!

Posted 24 July 2009 - 04:07 AM

I'll probably end up selling this one and get another laptop with a better card.


That's just it; your laptop doesn't even HAVE a video card.