Jump to content



Photo
- - - - -

Red Dead Redemption issue


  • Please log in to reply
4 replies to this topic

#1 cheapfrag

cheapfrag

Posted 17 August 2011 - 02:31 PM

So last year I played Red Dead Redemption when I had a free month of Blockbuster online. I beat the single player campaign and I really enjoyed the game. I don't usually like open world games - well I didn't like GTA4 I should say - but I really enjoyed the western setting of RDR. I played the game with no problems that I remember.

So recently I purchased RDR (used) and RDR: Undead Collection (used) during a GameStop B2G1 free sale because I wanted to play RDR some more, get more trophies and try the multi-player/free roam.

I think I briefly tried out both games to make sure they worked. I know I tried Undead for a little while until I was overwhelmed by zombies that killed me in town.

Well, I went to play RDR last night and it froze prior to getting to the title menu. I was able to get out by pressing the PS button and selecting Quit Game. I tried again. This time I got to the title menu and I selected single player and the game froze at while loading the game. This time I had to shut down the PS3. So I deleted the Game Save information and the Game Setting file and tried again. I was able to get to the main menu, select single player, it said something about a no save present and I chose create new save game, it said something about something being corrupted and that it would re-install, which it did and everything seemed good. Except the dialog cut out during the opening scene with John Marston on the train (i.e. I could not hear the conversation but I think there were other sounds/music) and then froze but eventually came back. When I got into the game, I went to the saloon and found Jake (my guide) and we got on our horse and started to ride. Then the game got all wacky, my horse shot ahead , went into the air, and the game froze.

Anyone have a clue how I could fix this issue. The game played perfectly last year. I have a PS3 60 GB model. I recently upgraded the HDD to a 320 GB WD Black drive which hasn't caused a problem for any other games. Could it be the HDD upgrade? Could it be the game disk itself (no scratches evident) Any suggestions?

#2 crzyboy88

crzyboy88

    This is a witty title

  • CAGiversary!

Posted 17 August 2011 - 02:38 PM

See if you can run the games on a friend's PS3. That would eliminate a couple of possibilities.
Posted Image

Posted Image

#3 guardian_owl

guardian_owl

    Keeper of the CAG Shrine

  • CAGiversary!

Posted 17 August 2011 - 05:12 PM

I had a similar problem when I have purchased games used at times. I had an old fat PS2 and bought a used God of War 2, it would play in slims but would keep skipping and freezing in my PS2 fat so I had to return it. I bought another used copy later on down the line and it worked fine.

Similar thing happened with Red Dead Redemption, purchased it used for my fat ps3 and dialogue kept skipping or the game kept freezing in the opening 10 minutes or so of the game so I had to return it, I plan to eventually purchase it new when the price drops.

Guardian_owl.png


#4 IAmTheCheapestGamer

IAmTheCheapestGamer

Posted 03 September 2011 - 10:13 AM

Do you know how to get into the PS3's 'safe mode', OP?

Here's a guide to tell you how to get into it. Try running "RESTORE FILE SYSTEM" from the list of options and see if that helps with your freezing issues.

That option is basically like a defrag for the system. It's helped in times past when I had games like GTA IV freeze on me.

Here's how to get into safe mode from the FAQ:

Activating Safe Mode

Step 1: Turn off the PLAYSTATION 3 by holding the Power button on the front of the unit till the Power light is red.
Step 2:

  • Touch and hold the Power button, you will hear the first beep, meaning the PLAYSTATION 3 is powering on.
  • Continue to hold the Power button and after about 5 seconds, you will hear a second beep, indicating the video reset.
  • Continue to hold the Power button and after about another 5 seconds you will hear a third beep and the system will power off (Power light is red).
Step 3:
  • Touch and hold the Power button, you will hear the first beep, again for the PLAYSTATION 3 to power on.
  • Continue to hold the Power button and after about 5 seconds, you will hear a second beep for video reset.
  • Continue to hold the Power button and after about another 5 seconds you will hear a quick double beep. At that point release the Power button. If you succeeded in activating Safe Mode, you will see a message on the screen saying, “Connect the controller using a USB cable and then press the PS button.”
  • Connect a USB cable to the controller and the PLAYSTATION 3 and press the PS button to enter Safe Mode.
  • Then you will see the Safe Mode menu.


i added a link to more wang pics. yu wang i mean not wang wang as in penis.

Sarcasm-Just one of the many services I offer.
Posted Image

#5 cheapfrag

cheapfrag

Posted 08 September 2011 - 06:59 PM

I ended up going back to GameStop and at first they said it was too long since I bought the game (about 2 months). But since the woman i was talking to was the manager and she's the one who sold me the games (according to the receipt), and when she asked why I hadn't played it in the 2 months since, I explained that I was playing the other games that I got with it under the B2G1Free, she said OK and proceeded to call around to locate another copy. She actually got her roommate (who works at a different store) to bring her the game that night and I picked it up the next day. I thought that was pretty good customer service and so I pre-ordered Uncharted 3.

The new disk works great. I think the old disk had a very small U-shaped stratch that may have been the cause of my problems.