My Mouse Stopped working


maybe a cag can help me. i woke up today and noticed my wireless mouse stopped working. i go to device manager and see a yellow triangle in the mouse section as follows......

mice and other pointing devices

   HID compliant mouse

      device status

          windows cannot load the device driver for this hardware. the driver may be corrupted or missing    (code 39)

         {bad file}

          the attributes of the specified mapping file for a section of memory cannot be read

its a USB mouse and i did the following and none of these worked

  • uninstalled/reinstalled drivers
  • checked all the usb ports and tried several mice including this one, on laptop and they work fine, just not on my pc
  • dug into the regedit files and deleted the upper filters
  • went to the logitech website and downloaded the most up to date drivers
  • totally bi passed the usb part and hooked up a PS/2 mouse and still no luck
i seriously dont have any idea what to do now. any suggestions would be great.


desperate times call for desperate measures. with my back against the wall i did a windows reinstall. the usb mouse still doesnt work, BUT this time the old school wired ps/2 mouse installed and i now have a working mouse.

[SIZE=10pt]My cat knocked coffee into my MacBook keyboard and Mr Fixreplaced it within a few hours for a great price.[/SIZE]

Last edited by a moderator:
A lot of devices stop working because of the old/bad drivers. It is easy to solve if you find the newest drivers. I had the same problem with another cheap wireless mouse. Nothing worked, the battery was good, my pc wasn’t broken, no bad usb ports. I found the fix with an awesome driver updater. This fixed my problem in a matter of minutes. I wasted 2 hours to find the fix, and only this helped me.

Last edited by a moderator:
bread's done