Jump to content

- - - - -

Assassin's Creed 3 - Please insert Disc 2 Issues

#1 Ken Lew   CAG in Training CAG in Training   29 Posts   Joined 4.8 Years Ago  

Posted 02 January 2013 - 04:35 AM

I was playing single player (On Xbox 360) when I got a party chat and game invite. I accepted it to get into the party, but declined the game invite part.

Now it is stuck with Please insert Assassin's Creed III Disc 2. I have inserted it, when through everything I had to, chose return to Disc 1 and it still has the error.

I've tried everything I could find. I have moved the save to a different place, I've restarted my Xbox, I've dashboarded and rebooted, but still no dice.

Has anyone had this issue or knows how to fix it?


#2 MSUHitman   Checkmate Arcade Co-Host CAGiversary!   13868 Posts   Joined 11.2 Years Ago  

Posted 02 January 2013 - 07:16 PM

Disc 2 is for the MP so if you're getting a game invite for AC 3 it's to play multiplayer.

Edit: I see what you're saying now. Maybe try going into AC 3 MP and have it fail to connect to the game then from the menu select single player for it to prompt for disc 1?

#3 lvjordan238   CAG Veteran CAGiversary!   45 Posts   Joined 10.0 Years Ago  


Posted 15 January 2013 - 09:24 PM

I had the same issue. Try signing out of your main gamertag and onto an alternate GT when you get the "Please insert Disc 2". Then start playing single player and the problem should be fixed.

#4 HydroX   Quintessential Studmuffin CAGiversary!   7199 Posts   Joined 8.6 Years Ago  

Posted 17 January 2013 - 01:51 AM

If that doesn't work, follow the Xbox Support canned answer: "try clearing your cache". ;)